Corregir el WordPress parse error instalando plugins

En varias ocasiones he intentado agregar algunos plugins a este blog basado en wordpress y me encontrado con un “error” poco agradable y mucho menos entendible cuando segun los stats del plugin dicen que funcionan correctamente con mi version de wordpress.

El error que presenta contiene la siguiente linea de error principal:

Buscando solución a este error, desde instalar versiones anteriores del plugin hasta la edición del código mismo y sin encontrar como repararlo. Decidí indagar en la web cuales plugins de wordpress presentan este error.

En el mejor de los casos la solución a este error es instalar el WordPress Plugin Framework Reloaded que es requerido para muchos plugins interesantes para wordpress como Author Box, Suscribers, entre otros.

Ahora bien, que pasa cuando instalando el WordPress Plugin Framework Reloaded para corregir el error tambien presenta el mismo error al ser instalado :S.

Al final encontré una solución de los mas extraña “por así decir”, pero que soluciona el problema definitivamente para que tanto el plugins que queremos instalar, y si en su caso, el WordPress Plugin Framework Reloaded también nos presenta el error al ser activado.

Actualiza tu PHP a la versión 5.x ya que este error significa que el plugin requiere esta versión de PHP aunque el plugin no te muestre el alerta como hacen algunos otros.

En algunos casos la version de PHP configurada para tu cuenta en el proveedor de hosting es la 4.x pero si encuentras que tu cuenta pudes actualizar hazlo. Otra alternativa es, probar creado un archivo .htaccess en su hosting y agregando la siguiente línea:

Si al hacer esto tu sitio presenta el error 403, significa que tu proveedor de hosting no tiene una version de PHP 5 instalada en el servidor que hospeda tu cuenta. Solicita update a PHP 5.x o cambia de proveedor de hosting.

  • Hola, Federico. Me gusta tu declaración de Webfilantropía y el sitio mismo. Sigue ahí, que vas bien.
    Carlos